Skip to:
Content

Opened 5 years ago

Closed 5 years ago

#2576 closed defect (fixed)

Update phpunit grunt task to not use deprecated util

Reported by: netweb Owned by: netweb
Milestone: 2.6 Priority: normal
Severity: normal Version: trunk
Component: Tools - Code Improvements Keywords:
Cc:

Description

Via #WP27343

Grunt is deprecating the Grunt.Util.* api (mentioned in the 0.4.3 announcement http://gruntjs.com/blog/2014-03-07-grunt-0.4.3-released and the 0.4.2 announcement http://gruntjs.com/blog/2013-11-21-grunt-0.4.2-released)

Related #2542

Attachments (1)

2576.diff (884 bytes) - added by netweb 5 years ago.

Download all attachments as: .zip

Change History (4)

#1 @netweb
5 years ago

Two options:

Switch to grunt-phpunit

  • We need to wait for an upstream fix to allow -d to be set for multisite
  • grunt-phpunit is already in our package.jsonthough it is not currently used

Replace grunt.util.spawn with the backwards compatible recommended npm module

@netweb
5 years ago

#2 @netweb
5 years ago

Upstream via 27343 we have gone with the method to include grunt-legacy-util

#3 @netweb
5 years ago

  • Owner set to netweb
  • Resolution set to fixed
  • Status changed from new to closed

In 5346:

Grunt is deprecating the Grunt.Util.* api, adding grunt-legacy-util will allow us to continue using grunt.util.spawn to spawn the multiple phpunit Grunt tasks.

  • Adds grunt-legacy-util to package.json
  • Requires fresh npm install to update dependencies
  • Props netweb. Fixes #2576
Note: See TracTickets for help on using tickets.