Skip to:
Content

bbPress.org

Opened 6 years ago

Closed 6 years ago

#2562 closed defect (duplicate)

Wrong default parameter value for "bbp_allow_global_access" function

Reported by: jbermudez Owned by:
Milestone: Priority: high
Severity: critical Version: 2.5.3
Component: General Keywords: needs-patch
Cc:

Description

According to the @param for this function, the default value should be false. However, the $default parameter is being set to 1 (true). For multisite, when the hook for bbp_set_current_user_default_role is called, the user will be added to the blog with the default role, even though an admin will not think this is the case based on the default setting in the settings screen. This can interfere with member restriction plugins and should be corrected ASAP.

Change History (4)

#1 @netweb
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing this as a duplicate of #2210

#2 @jbermudez
6 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Not sure how this is a dupe of that ticket... my request is very specific in that the bbp_allow_global_access function have the default parameter set to 0 instead of 1 to be in line with the comments. I can submit a diff if you like, but I thought it would be easy enough to do. I'll copy over my initial comment into that ticket as well.

#3 @jbermudez
6 years ago

Actually, nevermind. Apparently, the default is for the setting to be turned on, so just the function comments needs to be cleaned up.

#4 @jbermudez
6 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.