Skip to:
Content

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#2504 closed defect (fixed)

forums permalink does not display on smart phones

Reported by: artkahlich Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Appearance - Theme Compatibility Keywords:
Cc:

Description

When accessing a permalink of the form "http://mysite.com/forums/" the top level forums are displayed on a laptop/desktop machine with Chrome, Firefox and IE. On a smart phone a page with only the word "forums" is displayed, everything else is blank.

This is worked around by creating a new page for the top level forums and using the shortcode [bbp-forum-index] in the body of that page.

The most important part of the work around is to NOT use the same permalink ending in "/forums/" for this new page! In my case, my new page had a title of "Forums" which led to the same permalink and the same problem. When I changed the permalink to "/allforums/" for my top level forums page, it displayed properly on my smart phone.

Attachments (2)

2504-TwentyFourteen-400px.png (5.9 KB) - added by netweb 5 years ago.
2504-TwentyFourteen-401px.png (8.2 KB) - added by netweb 5 years ago.

Download all attachments as: .zip

Change History (20)

#1 @artkahlich
5 years ago

One other thing I noticed: when I am in a forum sub-category, at the top a set of links is displayed starting with Home Page > Forums. When I click on that Forums link on my Android smart phone, it does not take me to the work around page I created with a permalink of "/allforums/". Instead, it takes me back to the non-functional "/forums/" permalink - at least it is non-functional on my smart phone.

#2 @artkahlich
5 years ago

Another interesting observation: if I change my Forums page to have a permalink ending in "/forums/", I see that this page is displayed on my desktop browser whether I go there from a sidebar menu or from the Forums link on the top of a sub-forum. The reason I know this is because on my page with the "/forums/" permalink I have additional content besides the shortcode [bbp-forum-index] in the body of the page, and that content is displayed in both cases. So apparently for a desktop browser the "/forums/" permalink always goes to the page I made with that permalink, not the auto-generated forum index.

Switch to the Android browser and I apparently don't get the page I created in either case. Instead I get the auto-generated Forum index whether coming from the sidebar menu or the Forums link on the top of a sub-forum, which on Android doesn't work.

#3 @johnjamesjacoby
5 years ago

  • Keywords reporter-feedback added

Thanks for the report. I have a hunch this is might be happening because of some mobile specific code that's running, either as part of the theme, or another plugin.

bbPress performs some rather sophisticated trickery to automatically integrate into any existing WordPress theme, and my guess is that's where it's failing. Can you try a few things and report back:

  • Switch to any default theme
  • Deactivate other plugins one at a time, and test for the same bug
  • Test if this happens on iOS, or when resizing the browser down to a very small width

#4 @artkahlich
5 years ago

  • Keywords reporter-feedback removed

First, here is the easy answer to your last request. Take a look here, showing the same problem with a different user on iOS.

I do have a live blog and forum running this stuff, so any theme and plugin experiments will affect them. I will be trying this later at a time of day when I affect them less (I hope).

#5 @artkahlich
5 years ago

Second answer to your last request: If I narrow my desktop Firefox window down to as narrow as it will go, I get the same behavior as on my Android phone. I then went to my Android phone and rotated it to render in landscape mode, and the forums page rendered properly.

Seems to be definitely tied to render width.

#6 follow-up: @johnjamesjacoby
5 years ago

  • Component changed from General to Theme Compatability

To confirm, this is an incompatibility with the TwentyFourteen theme only?

#7 @artkahlich
5 years ago

I have tried "theme preview" with 2014 and it shows the problem. I have then tried "theme preview" with 2013 and 2012 - they do NOT show the problem.

So yes, this appears to be an incompatibility with the TwentyFourteen theme only.

#8 in reply to: ↑ 6 @netweb
5 years ago

Replying to johnjamesjacoby:

To confirm, this is an incompatibility with the TwentyFourteen theme only?

As soon as you hit 400px the Twenty Fourteen media query kicks in and bbPress is gone.

See 2504-TwentyFourteen-400px.png & 2504-TwentyFourteen-401px.png

#9 @johnjamesjacoby
5 years ago

Because of line 2991 in twentyfourteen/style.css:

.list-view .site-content .cat-links,
.list-view .site-content .entry-content,
.list-view .site-content .entry-summary,
.list-view .site-content footer.entry-meta {
	display: none;
}

I don't understand why anyone would want to hide the content area, but it would appear this is by design for the mobile screen size. Worth consulting with Lance Willet about the intention here, and whether or not this is working as expected.

#10 @johnjamesjacoby
5 years ago

  • Milestone changed from Awaiting Review to 2.6

We can likely force this with an !important rule on .entry-content but I'd really rather not. Should dave Lance chime in before making changes here.

Moving to 2.6 for some thought.

#11 follow-up: @lancewillett
5 years ago

A simpler fix would be to filter body_class to get rid of list-view for bbPress views.

#12 in reply to: ↑ 11 ; follow-up: @johnjamesjacoby
5 years ago

Replying to lancewillett:

A simpler fix would be to filter body_class to get rid of list-view for bbPress views.

That circumvents a larger issue IMO, which is the twentyfourteen theme assuming all archive pages are list views. Custom post type archives can have their own templates, and shouldn't be subjected to blog post styling.

In the twenty fourteen_body_classes() function, what happens if we change the is_archive() check to is_post_type_archive( 'post' ) ?

#13 in reply to: ↑ 12 ; follow-up: @lancewillett
5 years ago

Replying to johnjamesjacoby:

That circumvents a larger issue IMO, which is the twentyfourteen theme assuming all archive pages are list views. Custom post type archives can have their own templates, and shouldn't be subjected to blog post styling.
In the twenty fourteen_body_classes() function, what happens if we change the is_archive() check to is_post_type_archive( 'post' ) ?

Good points, and yes -- that solution should work without changing existing behavior. Want to start a Twenty Fourteen ticket for us in core Trac?

#14 in reply to: ↑ 13 @netweb
5 years ago

  • Version changed from 2.1 to 2.5

Replying to lancewillett:

Want to start a Twenty Fourteen ticket for us in core Trac?

Thanks Lance, Done #WP27031

This ticket was mentioned in IRC in #bbpress-dev by netweb. View the logs.


5 years ago

#16 @netweb
5 years ago

  • Milestone 2.6 deleted
  • Resolution set to fixed
  • Status changed from new to closed

This has now been patched in WordPress core via #WP27031/[WP27587]

Closing as fixed and thanks Lance.

#17 @johnjamesjacoby
5 years ago

Lance's CSS-only approach does not account for pages that use shortcodes. Can we confirm whether this is also fixed for us in that case?

#18 @netweb
5 years ago

Confirmed

The following work as expected:

  • [bbp-forum-index] on a page
  • /forums
  • [bbp-single-topic id=41894] on a page
  • /forums/topic/topic-one/
  • [bbp-single-view id="popular"]
  • /forums/view/popular/
  • [bbp-single-view id="no-replies"]
  • /forums/view/no-replies/
  • [bbp-forum-form]
  • [bbp-stats]
  • BuddyPress /members/admin/forums/
  • BuddyPress /groups/buddypress-public-group/forum/
Note: See TracTickets for help on using tickets.