Skip to:
Content

bbPress.org

Opened 6 years ago

Closed 3 years ago

#2499 closed defect (worksforme)

Edit log not stored when noting reason for moving a thread.

Reported by: arielmeadow Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Component - Topics Keywords:
Cc:

Description

What I did:

  1. Clicked edit on a thread:

http://awesomescreenshot.com/0fa25fk3d7

  1. On edit page, I changed forum category and made a note in the "edit log" section: http://awesomescreenshot.com/0ca25fk7ea

What I expected to happen:

  1. Thread is moved to new category
  2. Edit log appears at the end of the post, noting my edit log notes

What happens:

  1. Thread is moved to new category
  2. Edit log notes do NOT appear at the end of the post

http://awesomescreenshot.com/09925fkh21

I have confirmed that edit logs are stored and displayed just fine when editing a post that is NOT moved.

But when editing + moving, edit logs are not stored or displayed.

Change History (3)

#1 @netweb
6 years ago

  • Version changed from 2.1 to 2.5

I cannot reproduce this.

Repro Steps:

  1. Ensure revision logging is enabled in bbPress settings
  2. Edit a topic
  3. Add an edit reason
  4. Click Submit
  5. Optional: Select a new forum for the topic.

Works as expected with or without step 5 in that the topic has updated content and a revision log is included in the topic content.

Alternate revisions based on only moving a topic to a new forum

  1. Ensure revision logging is enabled in bbPress settings
  2. Open a topic via 'edit'
  3. Do not modify the topic content
  4. Select a new forum to move the topic to
  5. Add an edit reason
  6. Click submit

Again works as expected though no revision log is appended to the topic as we did not edit the content so no revision log is appended.

We are only updating _bbp_revision_log when the content is edited. We do not currently log split, move, spam, merge actions.

#2 @johnjamesjacoby
6 years ago

  • Component changed from General to Topics
  • Keywords reporter-feedback added
  • Milestone changed from Awaiting Review to Future Release

Can't duplicate this either. More information will be helpful

  • What theme are you using?
  • What other plugins do you have installed?
  • Has this ever worked? (Is this a recent bug introduced in 2.5?)
  • Are there any other circumstances where this happens?

#3 @netweb
3 years ago

  • Keywords reporter-feedback removed
  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Going to close this as no feedback in 3 years

Note: See TracTickets for help on using tickets.