Skip to:
Content

bbPress.org

Opened 6 years ago

Closed 4 years ago

#2486 closed defect (fixed)

Make bbPress Responsive in Search Result

Reported by: funnycat777 Owned by: netweb
Milestone: 2.6 Priority: normal
Severity: normal Version: trunk
Component: General - UI/UX Keywords: has-patch commit
Cc:

Description

Through Ticket #1933(http://bbpress.trac.wordpress.org/ticket/1933), bbpress became responsive.

Topics and replies look better now, however I found a problem in the bbPress search result page.

All "replies" are responsive, however "topics" still show in two columns, resulting in the waste of screen real estate. (See screenshot)

Please fix this layout problem.

Attachments (5)

Screenshot.png (163.4 KB) - added by funnycat777 6 years ago.
2486.diff (18.0 KB) - added by netweb 6 years ago.
2486.2.diff (19.6 KB) - added by netweb 6 years ago.
2486.3.diff (10.9 KB) - added by netweb 6 years ago.
2486.4.diff (4.5 KB) - added by netweb 5 years ago.

Download all attachments as: .zip

Change History (20)

#1 @johnjamesjacoby
6 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 2.6
  • Priority changed from high to normal

Will investigate in 2.6.

@netweb
6 years ago

#2 @netweb
6 years ago

  • Keywords has-patch added; needs-patch removed

Confirmed. Patch 2486.diff adds missing media queries for topics.

(Patch also adds some line spacing per WP Core CSS style guide)

#3 @netweb
6 years ago

Ping @alex-ye Can you take a look at the Media Queries RTL CSS (bbpress-rtl.css#L280), there are a few float: left; and text-align: left; that I am unsure if these should be right for RTL.

#4 @netweb
6 years ago

  • Owner set to netweb

I have to to check this patch, quite sure I have a mistake or two here.

Will come back to it today.

@netweb
6 years ago

#5 @netweb
6 years ago

In 2486.2.diff topics & search responsive media queries refreshed.

@netweb
6 years ago

#6 @netweb
6 years ago

In 2486.3.diff:

  • Patch refreshed against /trunk and removed depreciated RTL changes.

#7 @sooskriszta
5 years ago

  • Keywords needs-testing added

#8 follow-up: @Robkk
5 years ago

Im working on making the bbpress look a little better on smaller devices

I have even edited the way the search results look.

You can check out the progress here.

https://github.com/robkk/better-bbpress-responsive-theme

There is a little more i could do and i will probably be finished in the next few days.

I wouldnt mind if you take some css or php arrangement ideas and add it to 2.6

I might post pictures later on how it looks on this topic later.

@netweb
5 years ago

#9 @netweb
5 years ago

  • Keywords commit added; needs-testing removed

In 2486.4.diff​ a refresh of 2486.3.diff to apply cleanly against trunk.

#10 in reply to: ↑ 8 ; follow-up: @netweb
5 years ago

Replying to Robkk:

Im working on making the bbpress look a little better on smaller devices

I have even edited the way the search results look.

You can check out the progress here.

https://github.com/robkk/better-bbpress-responsive-theme

There is a little more i could do and i will probably be finished in the next few days.

I wouldnt mind if you take some css or php arrangement ideas and add it to 2.6

I might post pictures later on how it looks on this topic later.

Thanks Robkk, just had a quick look at your repo and I see all kinds of changes and updates to the CSS and templates which no doubt we can add and update bbPress to include many of these enhancements though each of these should be broken up into smaller pieces and new tickets created for each.

For now though lets run with 2486.4.diff for bbPress 2.6 as per this ticket to make the existing bbPress search results responsive with the existing styles.

#11 in reply to: ↑ 10 @Robkk
5 years ago

@netweb

Alright

And the only thing i can think of right now that i could make a new ticket for is maybe the way user pages look.

Especially the edit profile section.

The labels should be on top of the text input areas when the section is viewed on a smaller device.

#12 @netweb
5 years ago

Robin,

Create a ticket for that, or anything else you feel can be improved, if your not sure how to create an actual patch for the ticket/s I'll go through that with you in the ticket. :)

#13 @Robkk
5 years ago

@netweb My names Robert ,

for making patches it just seems i upload the file that i changed either full code or just the improvements.

so if i update the template loop-single-reply.php i just attach the same file with the new code since its a relatively small file anyway.

But if its a really big file like style.css or any template.php files i just post a section of the improved code.

Right??

And the Properties seem really easy to use to , like since my improvements are UI so i choose that, and so on.

#14 @netweb
5 years ago

Ha!, my bad I'm sure I meant to type Rob and not Robin above, sorry ;)

Create the new ticket and I'll go through how to create a patch with you in that ticket rather than adding more to this ticket, but suffice to say there is a little bit more to it than attaching a file, you need to have SVN or Git setup on your PC to create a patch but I'll go through that in the follow up ticket.

#15 @netweb
4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

In 5652:

CSS: Include relevant topic and search CSS classes alongside existing reply responsive media queries for mobile search results.

Props netweb. Fixes #2486

Note: See TracTickets for help on using tickets.