Skip to:
Content

Changeset 6204


Ignore:
Timestamp:
01/02/17 00:01:04 (3 months ago)
Author:
netweb
Message:

Unit Tests: Don't run BuddyPress PHPUnit tests on versions less than PHP 5.3.0

BuddyPress 2.8 has dropped support for PHP 5.2.x, this changeset updates the BuddyPress PHPUnit configuration to only run the tests on PHP versions greater than 5.3.0

See also https://bpdevel.wordpress.com/2016/07/21/php-5-2-bp-2-8-and-php-support-guidelines/

Fixes #3037.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/tests/phpunit/buddypress.xml

    r6030 r6204  
    1212    <testsuites> 
    1313        <testsuite> 
    14             <directory suffix=".php">./testcases/</directory> 
     14            <directory suffix=".php" phpVersion="5.3.0" phpVersionOperator=">=">./testcases/</directory> 
    1515        </testsuite> 
    1616    </testsuites> 
Note: See TracChangeset for help on using the changeset viewer.